Saturday, 6 September 2014

SQL SERVER 2008 - You must use the Role Management Tool to install or configure Microsoft .NET Framework 3.5.

While trying to install Visual Studio 2008 / SQL Server Management Studio or SQL Server Connectivity Tools on a Windows 2008 R2 machine you may get the following error.

You must use the Role Management Tool to install or configure Microsoft .NET Framework 3.5.

If you try to download .NET Framework 3.5 and install also it will give you error.

This is because Windows 2008 R2 already ships with the .NET 3.5.1 framework which needs to be enabled. You can enable the feature from Server Manager.

Steps:
1) Go To "Server Manager Console Window".
2) In the Console tree on the left, click Features.
3) In the Features pane click Add Features.
4) In the Add Features Wizard, select ".NET Framework 3.5.1 Features" and click Install.

Once you install the .NET Framework 3.5.1 Features from the Add Features Wizard in Server Manager, you can try installing VS 2008 / SSMS.

No comments:

Post a Comment